const regex = /<!--# include (\bvirtual\b|\bfile\b)=(\"|')(.+)(\"|').*-->/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--# include (\\bvirtual\\b|\\bfile\\b)=(\\"|\')(.+)(\\"|\').*-->', 'g')
const str = `{% ssi /home/django/cmsenv/cmsintegration/cms_pages/templates/test.html parsed %}
<!--# include file="/site_media/test2.js"-->
<!--# include file="/site_media/test.js"-->
<!--# include file='/site_media/media/test.js'-->
<!--# include virtual="/shop/getstates/1"-->
<!--# include virtual="/css"-->
<!--# include file='/site_media/test2.js'-->
<!--# include file='/site_media/test.js'-->
<!--# include file="/site_media/media/test.js"-->
{# EXTRA_CSS #}
{% if website.var.obj.extra_css %}
<style type="text/css">
{{ website.var.obj.extra_css|safe }}
</style>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}