package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bno\b|\bsin\b|nunca|evit(e|a|ar)|abstene|rehui|recusa).{0,16}(inici(e|es|ar)|abr(ir|as)|hacer|hagas|hace|reali(za|ce)|levant(a|e)|subir|crear|efectu[ea]|ingreses|gener[ae]).{0,16}reclamo`)
var str = `¡el producto que compraste fue entregado ¡muchas gracias alaineduardo. importante en caso de necesitar algun garantia o ajuste de talla, debes de contactarnos directamente por este chat o llamar al %tel y te ayudaremos. evita realizar cualquier reclamos antes de contactarnos para efectos de talla, garantia o servicio para poder brindarte una mejor atencion. de nuevo muchas gracias por tu confianza. saludos si le quedo grande puedes compra un ajustador en esta liga %url seguro por accidente y mantenimiento gratis piezas marloz a solo %num . pesos en esta liga %url`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}