re = /^((0[1-9])|([1-8][0-9])|(9[0-8])|(2A)|(2B)) *([0-9]{3})?$/i
str = '92 123'
# Print the match result
str.match(re) do |match|
puts match.to_s
end