$re = '/^\s*(?:(final)\s+)?(int|double|String|boolean|char)\s+(?:(?:(\w+)\s*(?:\=\s*(\w+))?\,?\s*)+)\;\s*$/';
$str = 'final String var_name = 3;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);