$re = '/([a-zA-Z0-9]+)[_-].*/';
$str = 'ilshoesx056_HITP0_2F
ilshoesx056_VMAX858_11F1
ilshoesx056_VMAX858_9F1
ilshoesx057_HITP0_1F
ilshoesx057_HITP0_2F
ilshoesx057_VMAX858_11F1
ilshoesx057_VMAX858_9F1
ilshoesx058_HITP0_1F
ilshoesx058_HITP0_2F
ilshoesx058_VMAX858_11F1
ilshoesx058_VMAX858_9F1
ilshoesx059_HITP0_1F
ilshoesx059_HITP0_2F
ilshoesx059_VMAX858_11F1
ilshoesx059_VMAX858_9F1
ilshoesx060_HITP0_1F
ilshoesx060_HITP0_2F
ilshoesx060_VMAX858_11F1
ilshoesx060_VMAX858_9F1
ilshoesx061_HITP0_1F
ilshoesx061_HITP0_2F
ilshoesx061_VMAX858_11F1
ilshoesx061_VMAX858_9F1
ilshoesx062_HITP0_1F
ilshoesx062_HITP0_2F';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);