import Foundation
let pattern = #"^P(([0-9]+Y)?([0-9]+M)?([0-9]+W)?([0-9]+D)?(T([0-9]+H)?([0-9]+M)?([0-9]+(\.?[0-9]+)?S)?))?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"^P(([0-9]+Y)?([0-9]+M)?([0-9]+W)?([0-9]+D)?)?(T(([0-9]+)H)?(([0-9]+)M)?(([0-9]+\.?[0-9]*)S)?)?$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}