$re = '/="([^"]*\.(?:png|jpeg|jpg|gif|bmp))"/Ui';
$str = 'position="left" poster="imagejpg"';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;