$re = '/(?=.*[A-Za-z])(?=.*[!@#\$%\^&\*])(?=.{7,})/mi';
$str = '
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);