re = /^1(1[2578]|2([09]80|3(45|)|5(3?0|5)|7[67])|414|6(200|(80|91)\d|99[015679])|8(28|91))|(2([1-8]\d|9[136])|30\d|7(0[789]|60)|80[08]|9([136]\d|[124-7]))(\d{6})$/m
str = '112
16912
1414
16805
16200
16804
211234567
707123456
760123456
911250000
911212000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end