package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([a-z0-9\.\-\_]{1,})@([a-z0-9\.\-\_]{3,})`)
var str = `First-middle.lastname@random-provider.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}