$re = '/(\d*).html/';
$str = 'http://www.lacentrale.fr/auto-occasion-annonce-22885696.html
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);