# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)\((?:[^()]+|(?R))*+\)"
test_str = ("Attribute VB_Name = \"mdl_WbkInits\"\n"
"Option Compare Database\n\n"
"Function InitWbk_004(byRef wbkRef x ())\n"
" Dim wbk As wbk_004_InstoreBrief\n\n"
" Set wbk = New wbk_004_InstoreBrief\n\n"
" Call wbk.wbk_Init(wbkRef)\n"
" \n"
" Set InitWbk_004 = wbk\n"
"End Function\n"
"Public Function InitWbk_003(ByRef wbkRef As Object) As Object\n\n"
" Dim wbk As wbk_003_3DCalculation\n\n"
" Set wbk = New wbk_003_3DCalculation\n\n"
" Call wbk.wbk_Init(wbkRef)\n"
" \n"
" Set InitWbk_003 = wbk\n"
"End Function\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.