import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![EB]#)[A-G](\\#|b)?";
final String string = "A\n"
+ "A#\n"
+ "Ab\n"
+ "B\n"
+ "Bb\n"
+ "C\n"
+ "C#\n"
+ "Cb\n"
+ "D\n"
+ "D#\n"
+ "Db\n"
+ "E\n"
+ "Eb\n"
+ "F\n"
+ "F#\n"
+ "Fb\n"
+ "G\n"
+ "G#\n"
+ "Gb\n"
+ "B#\n"
+ "E#\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}