re = /-?(?:[1-9][0-9]*)?[0-9]{4}-(1[0-2]|0[1-9])-(3[01]|0[1-9]|[12][0-9])/m
str = '2016-12-06
18-15-11
1981-01-01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end