package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^-?\d+\.*\d*;\s*-?\d+\.*\d*`)
var str = `52.686; -2.193`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}