using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*#?([A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})\s*$";
string input = @"aaaaaa";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}