// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<!--{if(\s+\(?(\$[^\s!=]+)[^}]+)}-->").unwrap();
let string = "<!--{if $projectdisplaymode != 'Widget'}-->
<!--{if (isset($projectdisplaymode ) && $projectdisplaymode != 'Widget' )}-->
<!--{if $runnow == 'true'}-->
<!--{if (isset($runnow ) && $runnow == 'true' )}-->
<!--{if $showdelete == 'Yes'}-->
<!--{if $average_rating_colorclass == 'progress0'}-->
<!--{if ($percentage!=\"\")}-->";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}