#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "failing[\w\W]*?\d*\)\s[\w\W]*?\:[\s\S]*?(Assert[\w\W]*?)[\n].*(src[^:]+):(\d+):(\d+)"
Local $sString = " 1) validates input" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 0 passing (660ms)" & @CRLF & _
" 1 failing" & @CRLF & _
"" & @CRLF & _
" 1) statement:propose validates input:" & @CRLF & _
" AssertionError: expected { Object (status, err) } to have a deep property 'err' of 'err1', but got 'Error while fetching the changes from the event store: {}'" & @CRLF & _
" at doAsserterAsyncAndAddThen (node_modules/chai-as-promised/lib/chai-as-promised.js:307:16)" & @CRLF & _
" at .<anonymous> (node_modules/chai-as-promised/lib/chai-as-promised.js:255:21)" & @CRLF & _
" at ctx.(anonymous function) [as property] " & @CRLF & _
" at src/aggregate/index.js:144:100" & @CRLF & _
"(node_modules/chai/lib/chai/utils/overwriteMethod.js:49:33)" & @CRLF & _
" at Context.<anonymous> (src/aggregate/test/index.js:44:36)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")