$re = '/^(ge\-[0-9]{1,2}\/[0-9]{1,2}\/[0-9]{1,2}([\.]?[0-9]{1,2})?)(\s+)(\w*)(\s*)(\w+(\-)?\w+)(\s*)(\w+(\-)?\w+$)?/m';
$str = '--- JUNOS 20.4R1.12 Kernel 32-bit JNPR-11.0-20201028.e1cef1d_buil
{master:0}
adminl2j@child-ex2300-24t>
dollar, euro, pound
{master:0}
adminl2j@child-ex2300-24t> show interfaces ge-0/0/0 terse
Interface Admin Link Proto Local Remote
ge-0/0/0 up AdminPort-Down
ge-1/1/1 uP HighStatus eth-switch
ge-0/0/88.12 uP High-Status eth-switch
ge-0/0/22 uP High-Status eth-switch
ge-20/11/0.0 up up protocol3
{master:0}
adminl2j@child-ex2300-24t> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);