package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w`)
var str = `Regex _ 2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}