import Foundation
let pattern = #"(?P<error_msg>.*?)(?:exit\s+code:\s+)(?P<exit_code>\d+).(?:Stdout:)(?P<stdout>.*?)(?:Stderr:)(?P<stderr>.*?)(?:CUSTOM_EOF)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
process "pipenv run pylint --rcfile .linting-configs/pylintrc ci/dagger/automation.py ci/dagger/async_interface.py ci/dagger/models/linting.py ci/dagger/models/config.py ci/dagger/linting.py ci/dagger/helper.py" did not complete successfully: exit code: 28
Stdout:
o snake_case naming style (invalid-name)
************* Module models.linting
ci/dagger/models/linting.py:9:0: C0115: Missing class docstring (missing-class-docstring)
ci/dagger/models/linting.py:15:22: C0103: Argument name "v" doesn't conform to snake_case naming style (invalid-name)
ci/dagger/models/linting.py:33:0: C0115: Missing class docstring (missing-class-docstring)
ci/dagger/models/linting.py:44:4: C0115: Missing class docstring (missing-class-docstring)
ci/dagger/models/linting.py:44:4: R0903: Too few public methods (0/2) (too-few-public-methods)
ci/dagger/models/linting.py:33:0: R0903: Too few public methods (1/2) (too-few-public-methods)
ci/dagger/models/linting.py:48:0: C0115: Missing class docstring (missing-class-docstring)
************* Module models.config
ci/dagger/models/config.py:6:0: C0115: Missing class docstring (missing-class-docstring)
ci/dagger/models/config.py:6:0: R0903: Too few public methods (0/2) (too-few-public-methods)
************* Module linting
ci/dagger/linting.py:37:4: W0613: Unused argument 'client' (unused-argument)
ci/dagger/linting.py:179:4: W0613: Unused argument 'client' (unused-argument)
ci/dagger/linting.py:240:4: W0613: Unused argument 'client' (unused-argument)
ci/dagger/linting.py:301:4: W0613: Unused argument 'client' (unused-argument)
ci/dagger/linting.py:5:0: W0611: Unused import click (unused-import)
ci/dagger/linting.py:7:0: W0611: Unused QueryError imported from dagger.exceptions (unused-import)
************* Module helper
ci/dagger/helper.py:51:0: C0116: Missing function or method docstring (missing-function-docstring)
ci/dagger/helper.py:88:0: C0115: Missing class docstring (missing-class-docstring)
ci/dagger/helper.py:122:0: C0116: Missing function or method docstring (missing-function-docstring)
ci/dagger/helper.py:133:19: W0212: Access to a protected member _raw_input of a client class (protected-access)
ci/dagger/helper.py:1:0: W0611: Unused getenv imported from os (unused-import)
-----------------------------------
Your code has been rated at 8.45/10
Stderr:
CUSTOM_EOF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)