$re = '/^((?=.*[a-z])(?=.*[A-Z])(?=.*[\d])(?=.*[@#%$£&*])\S{8,50})$/m';
$str = 'Testtest@3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);