$re = '/^(\s?\d{1,2}:\d{1,2})+$/';
$str = '10:45 24:00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);