re = /([a-z0-9]+\.)*(finalfantasyxiv\.com)*(\/)*(lodestone)*(\/)*(character)*(\/)*([0-9]+)/mi
str = 'http://eu.finalfantasyxiv.com/lodestone/character/2202576'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end