$re = '/^U{AA|AB|AE|OL|BA|BB|HL}/m';
$str = 'UOLEEDN17700389803';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);