using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (\S+) (\S+) \[([\w:/]+\s[+\-]\d{4})\] ""(\S+) (\S+)\s*(\S*)"" (\d{3}) (\S+)";
string input = @"127.0.0.1 - - [01/Aug/1995:00:00:01 -0400] ""GET /images/launch-logo.gif HTTP/1.0"" 200 1839";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}