$re = '/[0-9]+\s*([a-zA-Z]+\s*[a-zA-Z]+\s)*[0-9]*/';
$str = ' 7850 S Dean Martin Dr Ste 505';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);