$re = '/(?<![{a-zA-Z0-9_])[a-zA-Z_][a-zA-Z0-9_]*|[a-zA-Z_][a-zA-Z0-9_]*(?![}a-zA-Z0-9_])/';
$str = '{_sa2lary_} + {3+2} * 9 * 2 + 16464131630 + _sal4ary} + {salar7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);