$re = '/[^{\}]+(?=})/';
$str = 'Let get to {0} and get it setup for {1}. Ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);