package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?(\d|(\d+,?\d+))*(\.\d+)?(e\d+)?$`)
var str = `555,44.0e0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}