$re = '/^[\d|+][0-9]*$/m';
$str = '+94348758934758
094348758934758
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);