re = /(?x)
(?<=<td>)[^<>]+/m
str = '<table style="width:100%">
<tr>
<th>FirstName</th>
<th>LastName</th>
<th>Age</th>
</tr>
<tr>
<td>Jill</td>
<td>Nigam</td>
<td>25</td>
</tr>
<tr>
<td>PRanoy</td>
<td>Dewanjee</td>
<td>30</td>
</tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end