import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "study";
final String string = "In this study, we identified that rs7903146 has p = 5 * 10(-5) with 95% CI 0.97-1.12 and odds ratio 1.56. This result was obtained from a sample of American Indian recruited in California and Nevada. This SNP is known to affect the transcription and the pathway related to Three G-protein coupled receptors, the GRM7 metabotropic glutamate receptor, the orphan GPR154 and the HRH4 histamine receptor that are important to intracellular transduction.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}