# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:\/\/|\/\/)?(?:(?:www\.|m\.)?youtube(?:-nocookie)?\.com\/(?:(?:vi?|e|embed)\/([\w-]{11})|(?:watch|embed|attribution_link)?\?\S*?(?:(?<=\?v=|&v=)|(?<=\?vi=|&vi=))([\w-]{11}))|youtu\.be\/(?:([\w-]{11})(?!\S*v=)|\S*?(?:&v=|\?v=)([\w-]{11})))(?:[^\w-]\S*)?$"
test_str = ("My tests\n\n"
"https://www.youtube.com/watch?t=10&v=m_KBvP0_8Tc&sss\n\n"
"https://youtu.be/watch?v=e70VCVR-oQo&v=asdssssssss\n\n"
"https://youtu.be/watch?t=10s&v=e70VCVR-oQo\n\n"
"https://youtu.be/aaaaaaaaaaa?t=10&v=e70VCVR-oQo&v=asdssssssss\n\n"
"https://www.youtube.com/watch?t=10&v=e70VCVR-oQo&v=asdssssssss\n\n"
"http://youtu.be/oTJRivZTMLs&t=10\n\n\n\n"
"List of YouTube links I found online\n\n"
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0\n\n"
"https://www.youtube.com/embed/XNHjiJVz0ks?feature%3Doembed&display_name=YouTube&url=https://www.youtube.com/watch?v%3DXNHjiJVz0ks&image=https://i.ytimg.com/vi/XNHjiJVz0ks\n\n"
"http://www.youtube.com/watch?v=-wtIMTCHWuI/vi/XNHjiJVz0ks\n\n"
"https://www.youtube.com/watch?v=m_KBvP0_8Tc&v=asdssssssss\n\n"
"https://m.youtube.com/watch?v=m_kbvp0_8tc\n\n"
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n\n"
"http://youtu.be/-wtIMTCHWuI\n\n"
"https://www.youtube.com/watch?v=m_KBvP0_8Tc\n\n"
"https://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n\n"
"https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n\n"
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n\n"
"https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n\n"
"https://www.youtube.com/embed/0zM3nApSvMg?rel=0\n\n"
"//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0\n\n"
"https://www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0\n\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n\n"
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n\n"
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be\n\n"
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n\n"
"https://www.youtube.com/watch?v=peFZbP64dsU\n\n"
"http://youtube.com/v/peFZbP64dsU?feature=youtube_gdata_player\n\n"
"http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n"
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n"
"https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n\n"
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n\n"
"http://www.youtube.com/embed/dQw4w9WgXcQ\n\n"
"http://www.youtube.com/v/dQw4w9WgXcQ\n\n"
"http://www.youtube.com/e/dQw4w9WgXcQ\n\n"
"http://www.youtube.com/?v=dQw4w9WgXcQ\n\n"
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
"http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0\n\n"
"https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n\n"
"http://www.youtube.com/watch?v=oTJRivZTMLs&feature=youtu.be\n\n"
"http://youtu.be/oTJRivZTMLs&feature=channel\n\n"
"http://www.youtube.com/embed/oTJRivZTMLs?rel=0\n\n"
"http://youtube.com/vi/oTJRivZTMLs&feature=channel\n\n"
"http://youtube.com/?v=oTJRivZTMLs&feature=channel\n\n"
"http://youtube.com/?feature=channel&v=oTJRivZTMLs\n\n"
"http://youtube.com/?vi=oTJRivZTMLs&feature=channel\n\n"
"http://youtube.com/watch?v=oTJRivZTMLs&feature=channel\n\n"
"http://youtube.com/watch?vi=oTJRivZTMLs&feature=channel")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.