$re = '/^(?=^.{8,}$)(?=.*[a-z])(?=.*\d)(?=.*[A-Z]).*$/m';
$str = 'Rami123456
Passwordsd23
pass123142';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);