re = /^\[(\w+)\]$/m
str = '[abilities]
UnknownName = ??? Ability
UnknownDescFun0 = No description.
UnknownDescTech0 = This ability does not seem to have any purpose.
OneHitDeathName = 1-Hit Hero Badge
OneHitDeathDesc0 = You die in one hit. Only for the brave!
AddElement = Test Text.
SuckInOrbsName = Item Magnet Badge
SuckInOrbsFun0 = Item just out of reach? No longer a problem!
SuckInOrbsTech0 = Automatically attract nearby collectibles!"
[spac_eship]
[spac_eship]hub_alert_generic0 = …
hub_alert_generic1 = [icon:trophy][trophy]今年度鳥映画アワード[/trophy]は内部の者によって不正に染まっていた。
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end