// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(-|\d)+(\.\d{1,2})?").unwrap();
let string = "-100.00
1,000.00
100,000.00
1,000,000.00
00.7
0.00
-0909099993.2899999999999974
-3.2899999999999974
^(?!0\\.00)[1-9]\\d{0,2}(,\\d{3})*(\\.\\d\\d)?$
BOM
(-|\\d)+(?=(\\d{3})+(\\d{3})+(\\.\\d{1,2}))
BOM
^(-|\\d)(\\d{1,3})(\\.\\d{1,2})?
(\\w[-._+\\w]*\\w@\\w[-._\\w]*\\w\\.\\w{2,3})
^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$
.replace(/(\\d)(?=(\\d{3})+(?!\\d))/g, \"$1,\") # => \"10,000\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}