$re = '/^\+234(7[0]|8[01]|9[01])\d.{07,08}$/m';
$str = '+23470456
+2348145646767';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);