import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b91|\\b0|\\b)([6-9]\\d{9})\\b";
final String string = "9207323601\n"
+ "8343434349\n"
+ "6790312345\n"
+ "9739393939\n"
+ "7777598086\n"
+ "my number is 7777598086\n"
+ "7777598086-\n"
+ "91-7777598086\n"
+ "+91-7777598086\n"
+ "+917777598086\n"
+ "+917777598086 is my number\n"
+ "07777598086\n"
+ "+91-07777598086\n\n"
+ "invalid inputs:\n"
+ "92073236011\n"
+ "47777598086\n"
+ "s77777598086\n"
+ "77777598086s\n"
+ "777777598086\n"
+ "1077777598086\n"
+ "+91077777598086\n"
+ "123149177777598086";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}