#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/)?(?:www.)?instagram.com\/?([a-zA-Z0-9\.\_\-]+)?\/([p]+)?([reel]+)?([tv]+)?([stories]+)?\/([a-zA-Z0-9\-\_\.]+)\/?([0-9]+)?"
Local $sString = "// Group 2" & @CRLF & _
"https://www.instagram.com/p/CKYJRXVnwMO/?utm_source=ig_web_copy_link" & @CRLF & _
"instagram.com/p/CKYJRXVnwMO" & @CRLF & _
"www.instagram.com/p/CKYJRXVnwMO" & @CRLF & _
"https://www.instagram.com/taiga765/p/CYS-O2Gr8xZ/?utm_medium=copy_link" & @CRLF & _
"https://www.instagram.com/y.uuno/p/CXR5ATPls5M/?utm_medium=copy_link" & @CRLF & _
"// Group 3" & @CRLF & _
"http://www.instagram.com/reel/CRftq6QgG89/?utm_source=ig_web_copy_link" & @CRLF & _
"instagram.com/reel/CRftq6QgG89/" & @CRLF & _
"www.instagram.com/reel/CRftq6QgG89/" & @CRLF & _
"https://www.instagram.com/reel/CXR2xvbgCKW/?utm_medium=copy_link" & @CRLF & _
"// Group 4" & @CRLF & _
"https://www.instagram.com/tv/CN4RZWGn5wS/?utm_source=ig_web_copy_link" & @CRLF & _
"instagram.com/tv/CN4RZWGn5wS/" & @CRLF & _
"www.instagram.com/tv/CN4RZWGn5wS/" & @CRLF & _
"// Group 5" & @CRLF & _
"https://www.instagram.com/stories/sintha_tatha/2725190842360050880/" & @CRLF & _
"https://www.instagram.com/stories/urkawaiibae/2725982322342818754/" & @CRLF & _
"https://www.instagram.com/stories/willypangestu_/2725773180739197900/" & @CRLF & _
"https://www.instagram.com/stories/atrisna477769/" & @CRLF & _
"" & @CRLF & _
"https://www.instagram.com/stories/highlights/17910460144693951/" & @CRLF & _
"www.instagram.com/stories/highlights/17879710684406193/" & @CRLF & _
"instagram.com/stories/highlights/17879710684406193/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")