# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0]?[1-9]|[1][012])(?:\s*)(Oca(?:k)?|Sub(?:at)?|Şub(?:at)?|Mar(?:t)?|Nis(?:an)?|May(?:ıs)?|Haz(?:iran)?|Tem(?:muz)?|Ağus(?:tos)?|Eyl(?:lül)?|Eylül|Ekim|Kas(?:ım)?|Ara(?:lık)?)(?:\s*)([0-9]{1,4})(?:\s*|\s*\-\s*)(?:\s*)(([0-9]{1,2}\:[0-9]{1,2}\:[0-9]{1,2})|[0-9]{1,2}\:[0-9]{1,2})"
test_str = "03 Subat 2017 - 17:47:25"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.