#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{6,}$)((?=.*\w)(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[|!"$%&\/\(\)\?\^\'\\\+\-\*]))^.*"
Local $sString = "my valid 2passwoRd+" & @CRLF & _
"my missing number passwoRd+" & @CRLF & _
"MY MISSING LOWERCASE LETTER 2PASSWORD+" & @CRLF & _
"my missing uppercase letter 2passwod+" & @CRLF & _
"my missing special character 2passwoRd" & @CRLF & _
"not valid password"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")