// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[[:graph:]]+@[[:graph:]]+\.[[:graph:]]+").unwrap();
let string = "6x7 456 78993 45528 8382 837372 82 128 8282 82 828282 28 8282635372892 838
Lorem ipsum dolor 335-5555555 sit amet, consectetur adipisci5555555555 elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis 4@4 nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid e Mario ROSSI x ea commodi Fabio DE LUIGI cons mail@test.com equatur. 3835555555 Quis aute iure reprehenderit in voluptate 555/555555velit esse cillum HOMAWI @dolore eu fugiat nulla pariatur. 43434734 343 3 464 56 @5 65 6 5 757 676 Microsoft Office.
Excepteur sint Vaalima obcaecat Digital Forensics 192.168.3.45 cupiditat non RSSNDR74D04A271P proident, sunt in Sabrox bombazzi culpa qui officia de@serunt mollit anim id est laborum. Lorem ipsum Dr.Torsby dolor sit amet, consec 234 546 367 2789 Veldrin tetur adipisci yourken elit,347/5555555 sed eiusm 565437 od tempor incidunt ut labore et Andrea dolore magna aliqua. Ut enim ad minim TELEFUNKEN elin@unita15.no.it
FRODENO Jan enim ad minim 555-555555veniam, quis rssndr74d04a271u Zhang YUNING nostrum exercitatio@nem ullam 10.5.6.1corporis Vaalima suscip Wu LEI it laboriosam, nisi ut aliquid ex ea commodi Arael cons@equatur. Quis aute iure r328 5555555 eprehenderit in volup6767676767 6767676767tate 555 555555velit PLANESCAPE esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint obcae67676767676767676cat Soul Thosiel rssndr74D04A271U cupidita34567893 t non proident, sunt in culpa qui officia deserunt mollit Abdul-Wahaab Vaalima anim id est laborum. 388.555555 Lorem rSsndr74d04a271u ipsum cinnamomo@cengia.eu dolor sit amet, consectetur adipisci elit, sed Rosa eiusmod tempor Aimar incidunt ut labore et dolore magna a6767676767 32252525 353535 5353535liqua. Ut enim ad minim";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}