using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w{4}\b";
string input = @"Lorem ipsum dolor sit amet consectetur adipiscing elit nullam justo donec, morbi eros natoque velit blandit pharetra viverra condimentum curabitur magnis imperdiet, lacus quis libero dapibus dictum varius habitant dis mollis. Hac consectetur volutpat est taciti placerat dictumst sagittis luctus habitasse fringilla vel, vitae ornare at magna velit curabitur leo aptent dignissim etiam. Ullamcorper potenti egestas rutrum blandit suscipit dapibus cursus mollis sit, nec enim habitant congue nullam vehicula massa nascetur bibendum litora, fusce a inceptos hac nunc eget mauris non. Facilisis hac congue magna vivamus nunc finibus posuere scelerisque quisque ut, taciti non maximus vel cubilia dolor nisl sapien mattis sit, curabitur ullamcorper litora sagittis aenean urna mus tortor torquent. Conubia erat morbi himenaeos massa risus tempus et, a praesent nibh fringilla mus quisque pharetra turpis, rhoncus quis eros blandit potenti mattis. Nam egestas maecenas ridiculus morbi lacus dictum porttitor mi, in natoque parturient velit fusce eu at ornare, hendrerit amet est potenti dui nunc iaculis. Turpis aliquam sollicitudin magnis class massa est nullam mi per porta, eu finibus id ipsum vitae urna nisl porttitor nisi habitasse quisque, leo gravida tincidunt parturient suscipit vivamus maecenas iaculis libero. Adipiscing neque phasellus morbi inceptos vitae mauris ridiculus magna sed, netus etiam id tristique eget et himenaeos faucibus mi, curabitur sodales pulvinar proin ultrices ut tempus velit.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}