// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(?:([-‐‑‒–—―−⁃﹘﹣-])|(?:&(?:(?:#x(2d|201[0-5]|2212|2043|fe58|fe63|ff0d))|(?:#(45|820[89]|821[0123]|8722|8259|65112|65123|65293))|(hyphen|[nm]?dash|hybull|horbar|minus));?))").unwrap();
let string = "This captures an entity even if it lacks the ';', which is commonly encountered in the wild.
kbdash - - - - -; -
dash ‐ ‐ ‐ ‐ ‐ ‐; ‐
hyphen ‑ ‐ ‑ ‑ ‑ ‑; ‑
figure ‒ ‒ ‒ ‒ ‒; ‒
em – – – – – –; –
en — — — — — —; —
horbar ― ― ― ― ― ―; ―
minus − − − − − −; −
hybull ⁃ ⁃ ⁃ ⁃ ⁃ ⁃; ⁃
fe58 ﹘ ﹘ ﹘ ﹘ ﹘; ﹘
fe63 ﹣ ﹣ ﹣ ﹣ ﹣; ﹣
ff0d - - - - -; -
(?:([-‐‑‒–—―−⁃﹘﹣-])|(?:&(?:(?:#x(2d|201[0-5]|2212|2043|fe58|fe63|ff0d))|(?:#(45|820[89]|821[0123]|8722|8259|65112|65123|65293))|(hyphen|[nm]?dash|hybull|horbar|minus));?))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}