$re = '/https:\/\/([a-z\.]{4})?([0-9]+.hs-sites|wthubspot|hubspot).com[\/]?/m';
$str = 'https://hubspot.com
https://www.hubspot.com/
https://wthubspot.com/
https://123456.hs-sites.com/
https://google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);