import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b(T\\s|void\\s)(\\w+<T>)\\(.*\\);|(\\w+[<?\\w+>?]*\\s)(\\w+)\\b((\\s\\{[get;\\|private get;|set;]+)|\\(.*\\));)";
final String string = "void Something();\n"
+ "int SomethingElse(Parameter parameter);\n"
+ "List<Something> SomethingVeryElse(One one, Two two);\n"
+ "T Get<T>(params object[] args);\n"
+ "IEnumerable<Plugin> Plugins { get; }\n"
+ "void Set<T>(Func<T> constructor, params object[] args);\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}