// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^weight.+average.+(\n.+){0,2}(share|basic|ordinary).+(?P<d1>\s[\d,]+)\s+(?P<d2>\s[\d,]+)").unwrap();
let string = "VITROX CORPORATION BERHAD
(Incorporated in Malaysia)
Company No: 200401011463 (649966-K)
QUARTERLY REPORT ON RESULTS FOR THE SECOND QUARTER ENDED 30 JUNE 2020
B. DISCLOSURE REQUIREMENTS AS SET OUT IN APPENDIX 9B OF BURSA SECURITIES
MAIN MARKET LISTING REQUIREMENTS (cont’d)
B10 Earnings per share
INDIVIDUAL QUARTER CUMULATIVE QUARTER
Corresponding
Corresponding Current preceding
Current quarter preceding period-to-date period-to-date
ended quarter ended ended ended
30-Jun-20 30-Jun-19 30-Jun-20 30-Jun-19
Profit attributable to owners of
the Company (RM'000) 22,922 24,387 43,987 48,003
Weighted average number of
shares for computing basis
earnings per share ('000) 471,092 470,718 471,092 470,718
Basic earnings per share (sen) 4.87 5.18 9.34 10.20
Weighted average number of
shares for computing diluted
earnings per share ('000) 472,121 4 71,896 472,121 471,896
Diluted earnings per share (sen) 4.86 5.17 9.32 10.17
B11 Auditors’ report on preceding annual financial statements
The auditors’ report on the financial statements for the year ended 31 December 2019 was not subject to
any qualification.
13 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}