package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$?\d+(?:\.\d+)?`)
var str = `[X: $1.19] [Y: $5.29] [Z 999/1000]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}