re = /^(?=.*[A-Z])[a-zA-zÀ-ÖØ-öø-ÿœŒ\s\-\']+$/m
str = 'Hélène
Hélène-à-la-plage
e
Hé'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end